What’s Vulnerable › Vulnerabilities
CVE-2015-8969
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-11-03 · updated 2026-06-17
- Weakness: CWE-77
Description
git-fastclone before 1.0.5 passes user modifiable strings directly to a shell command. An attacker can execute malicious commands by modifying the strings that are passed as arguments to "cd " and "git clone " commands in the library.
Affected products
- git-fastclone ruby gem All versions before 1.0.1: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: git-fastclone ruby gem All versions before 1.0.1 1.0.5. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/81433
- https://github.com/square/git-fastclone/pull/5
- https://hackerone.com/reports/105190
- http://www.securityfocus.com/bid/81433
- https://github.com/square/git-fastclone/pull/5
- https://hackerone.com/reports/105190
Get alerted when CVE-2015-8969 or the next vulnerability affects your stack