What’s Vulnerable › Vulnerabilities
CVE-2015-8972
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-01-23 · updated 2026-06-17
- Weakness: CWE-119
Description
Stack-based buffer overflow in the ValidateMove function in frontend/move.cc in GNU Chess (aka gnuchess) before 6.2.4 might allow context-dependent attackers to execute arbitrary code via a large input, as demonstrated when in UCI mode.
Affected products
- GNU Chess: before 6.2.4 — fixed in 6.2.4
How to fix
Upgrade to a fixed version: GNU Chess 6.2.4. Check the vendor advisory for mitigations.
References
- http://lists.gnu.org/archive/html/bug-gnu-chess/2015-10/msg00002.html
- http://svn.savannah.gnu.org/viewvc/chess?revision=134&view=revision
- http://www.openwall.com/lists/oss-security/2016/11/13/2
- http://www.openwall.com/lists/oss-security/2016/11/14/11
- http://www.openwall.com/lists/oss-security/2016/11/14/12
- http://lists.gnu.org/archive/html/bug-gnu-chess/2015-10/msg00002.html
- http://svn.savannah.gnu.org/viewvc/chess?revision=134&view=revision
- http://www.openwall.com/lists/oss-security/2016/11/13/2
- http://www.openwall.com/lists/oss-security/2016/11/14/11
- http://www.openwall.com/lists/oss-security/2016/11/14/12
Get alerted when CVE-2015-8972 or the next vulnerability affects your stack