What’s Vulnerable › Vulnerabilities
CVE-2015-8985
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-20 · updated 2026-06-17
- Weakness: CWE-19
Description
The pop_fail_stack function in the GNU C Library (aka glibc or libc6) allows context-dependent attackers to cause a denial of service (assertion failure and application crash) via vectors related to extended regular expression processing.
Affected products
- GNU C Library (glibc): before 2.28 — fixed in 2.28
How to fix
Upgrade to a fixed version: GNU C Library (glibc) 2.28. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2017/02/14/9
- http://www.securityfocus.com/bid/76916
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=779392
- https://security.gentoo.org/glsa/201908-06
- http://www.openwall.com/lists/oss-security/2017/02/14/9
- http://www.securityfocus.com/bid/76916
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=779392
- https://security.gentoo.org/glsa/201908-06
Get alerted when CVE-2015-8985 or the next vulnerability affects your stack