What’s Vulnerable › Vulnerabilities
CVE-2015-9236
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-31 · updated 2026-06-17
- Weakness: CWE-284
Description
Hapi versions less than 11.0.0 implement CORS incorrectly and allowed for configurations that at best returned inconsistent headers and at worst allowed cross-origin activities that were expected to be forbidden. If the connection has CORS enabled but one route has it off, and the route is not GET, the OPTIONS prefetch request will return the default CORS headers and then the actual request will go through and return no CORS headers. This defeats the purpose of turning CORS on the route.
Affected products
- HackerOne hapi node module: before 11.0.0 — fixed in 11.0.0
How to fix
Upgrade to a fixed version: HackerOne hapi node module 11.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/hapijs/hapi/issues/2840
- https://github.com/hapijs/hapi/issues/2850
- https://nodesecurity.io/advisories/45
- https://github.com/hapijs/hapi/issues/2840
- https://github.com/hapijs/hapi/issues/2850
- https://nodesecurity.io/advisories/45
Get alerted when CVE-2015-9236 or the next vulnerability affects your stack