What’s Vulnerable › Vulnerabilities
CVE-2015-9238
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-31 · updated 2026-06-17
- Weakness: CWE-697
Description
secure-compare 3.0.0 and below do not actually compare two strings properly. compare was actually comparing the first argument with itself, meaning the check passed for any two strings of the same length.
Affected products
- HackerOne secure-compare node module: before 3.0.1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: HackerOne secure-compare node module 3.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/vdemedes/secure-compare/pull/1
- https://nodesecurity.io/advisories/50
- https://github.com/vdemedes/secure-compare/pull/1
- https://nodesecurity.io/advisories/50
Get alerted when CVE-2015-9238 or the next vulnerability affects your stack