What’s Vulnerable › Vulnerabilities
CVE-2015-9241
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-05-29 · updated 2026-06-17
- Weakness: CWE-400
Description
Certain input passed into the If-Modified-Since or Last-Modified headers will cause an 'illegal access' exception to be raised. Instead of sending a HTTP 500 error back to the sender, hapi node module before 11.1.3 will continue to hold the socket open until timed out (default node timeout is 2 minutes).
Affected products
- HackerOne hapi node module: before 11.1.3 — fixed in 11.1.3
How to fix
Upgrade to a fixed version: HackerOne hapi node module 11.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/hapijs/hapi/commit/aab2496e930dce5ee1ab28eecec94e0e45f03580
- https://github.com/jfhbrook/node-ecstatic/pull/179
- https://nodesecurity.io/advisories/63
- https://github.com/hapijs/hapi/commit/aab2496e930dce5ee1ab28eecec94e0e45f03580
- https://github.com/jfhbrook/node-ecstatic/pull/179
- https://nodesecurity.io/advisories/63
Get alerted when CVE-2015-9241 or the next vulnerability affects your stack