What’s Vulnerable › Vulnerabilities
CVE-2015-9242
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-29 · updated 2026-06-17
- Weakness: CWE-400
Description
Certain input strings when passed to new Date() or Date.parse() in ecstatic node module before 1.4.0 will cause v8 to raise an exception. This leads to a crash and denial of service in ecstatic when this input is passed into the server via the If-Modified-Since header.
Affected products
- HackerOne ecstatic node module: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: HackerOne ecstatic node module 1.4.0. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/v8/issues/detail?id=4640
- https://github.com/jfhbrook/node-ecstatic/pull/179
- https://nodesecurity.io/advisories/64
- https://bugs.chromium.org/p/v8/issues/detail?id=4640
- https://github.com/jfhbrook/node-ecstatic/pull/179
- https://nodesecurity.io/advisories/64
Get alerted when CVE-2015-9242 or the next vulnerability affects your stack