What’s Vulnerable › Vulnerabilities
CVE-2015-9262
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-01 · updated 2026-06-17
- Weakness: CWE-119
Description
_XcursorThemeInherits in library.c in libXcursor before 1.1.15 allows remote attackers to cause denial of service or potentially code execution via a one-byte heap overflow.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04
- Debian Linux: 8.0
- Tower: 3.3
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
- X Libxcursor: before 1.1.15 — fixed in 1.1.15
How to fix
Upgrade to a fixed version: X Libxcursor 1.1.15. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:3059
- https://access.redhat.com/errata/RHSA-2018:3505
- https://bugs.freedesktop.org/show_bug.cgi?id=90857
- https://cgit.freedesktop.org/xorg/lib/libXcursor/commit/?id=897213f36baf6926daf6d192c709cf627aa5fd05
- https://lists.debian.org/debian-lts-announce/2018/08/msg00016.html
- https://usn.ubuntu.com/3729-1/
- https://access.redhat.com/errata/RHSA-2018:3059
- https://access.redhat.com/errata/RHSA-2018:3505
- https://bugs.freedesktop.org/show_bug.cgi?id=90857
- https://cgit.freedesktop.org/xorg/lib/libXcursor/commit/?id=897213f36baf6926daf6d192c709cf627aa5fd05
- https://lists.debian.org/debian-lts-announce/2018/08/msg00016.html
- https://usn.ubuntu.com/3729-1/
Get alerted when CVE-2015-9262 or the next vulnerability affects your stack