What’s Vulnerable › Vulnerabilities
CVE-2015-9267
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-10-01 · updated 2026-06-17
- Weakness: CWE-269
Description
Nullsoft Scriptable Install System (NSIS) before 2.49 uses temporary folder locations that allow unprivileged local users to overwrite files. This allows a local attack in which either a plugin or the uninstaller can be replaced by a Trojan horse program.
Affected products
- Debian Linux: 8.0
- Nullsoft Scriptable Install System: before 2.49 — fixed in 2.49
How to fix
Upgrade to a fixed version: Nullsoft Scriptable Install System 2.49. Check the vendor advisory for mitigations.
References
- http://jvn.jp/en/jp/JVN68418039/index.html
- https://lists.debian.org/debian-lts-announce/2018/11/msg00041.html
- https://sourceforge.net/p/nsis/bugs/1125/
- http://jvn.jp/en/jp/JVN68418039/index.html
- https://lists.debian.org/debian-lts-announce/2018/11/msg00041.html
- https://sourceforge.net/p/nsis/bugs/1125/
Get alerted when CVE-2015-9267 or the next vulnerability affects your stack