What’s Vulnerable › Vulnerabilities
CVE-2015-9268
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-10-01 · updated 2026-06-17
- Weakness: CWE-20
Description
Nullsoft Scriptable Install System (NSIS) before 2.49 has unsafe implicit linking against Version.dll. In other words, there is no protection mechanism in which a wrapper function resolves the dependency at an appropriate time during runtime.
Affected products
- Debian Linux: 8.0
- Nullsoft Scriptable Install System: before 2.49 — fixed in 2.49
How to fix
Upgrade to a fixed version: Nullsoft Scriptable Install System 2.49. Check the vendor advisory for mitigations.
References
- http://jvn.jp/en/jp/JVN68418039/index.html
- https://lists.debian.org/debian-lts-announce/2018/11/msg00041.html
- https://sourceforge.net/p/nsis/bugs/1125/
- http://jvn.jp/en/jp/JVN68418039/index.html
- https://lists.debian.org/debian-lts-announce/2018/11/msg00041.html
- https://sourceforge.net/p/nsis/bugs/1125/
Get alerted when CVE-2015-9268 or the next vulnerability affects your stack