What’s Vulnerable › Vulnerabilities
CVE-2015-9286
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-30 · updated 2026-06-17
- Weakness: CWE-79
Description
Controllers.outgoing in controllers/index.js in NodeBB before 0.7.3 has outgoing XSS.
Affected products
- NodeBB: before 0.7.3 — fixed in 0.7.3
How to fix
Upgrade to a fixed version: NodeBB 0.7.3. Check the vendor advisory for mitigations.
References
- https://github.com/NodeBB/NodeBB/compare/56b79a9...4de7529
- https://github.com/NodeBB/NodeBB/pull/3371
- https://vulners.com/securityvulns/SECURITYVULNS:DOC:32625
- https://www.vulnerability-lab.com/get_content.php?id=1608
- https://github.com/NodeBB/NodeBB/compare/56b79a9...4de7529
- https://github.com/NodeBB/NodeBB/pull/3371
- https://vulners.com/securityvulns/SECURITYVULNS:DOC:32625
- https://www.vulnerability-lab.com/get_content.php?id=1608
Get alerted when CVE-2015-9286 or the next vulnerability affects your stack