What’s Vulnerable › Vulnerabilities
CVE-2015-9383
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-03 · updated 2026-06-17
- Weakness: CWE-125
Description
FreeType before 2.6.2 has a heap-based buffer over-read in tt_cmap14_validate in sfnt/ttcmap.c.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04
- Debian Linux: 8.0
- FreeType: before 2.6.2 — fixed in 2.6.2
How to fix
Upgrade to a fixed version: FreeType 2.6.2. Check the vendor advisory for mitigations.
References
- http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=57cbb8c148999ba8f14ed53435fc071ac9953afd
- https://lists.debian.org/debian-lts-announce/2019/09/msg00002.html
- https://savannah.nongnu.org/bugs/?46346
- https://usn.ubuntu.com/4126-1/
- https://usn.ubuntu.com/4126-2/
- http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=57cbb8c148999ba8f14ed53435fc071ac9953afd
- https://lists.debian.org/debian-lts-announce/2019/09/msg00002.html
- https://savannah.nongnu.org/bugs/?46346
- https://usn.ubuntu.com/4126-1/
- https://usn.ubuntu.com/4126-2/
Get alerted when CVE-2015-9383 or the next vulnerability affects your stack