What’s Vulnerable › Vulnerabilities
CVE-2015-9431
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-26 · updated 2026-06-17
- Weakness: CWE-352
Description
The qtranslate-x plugin before 3.4.4 for WordPress has CSRF with resultant XSS via the wp-admin/options-general.php?page=qtranslate-x json_config_files or json_custom_i18n_config parameter.
Affected products
- Qtranslate X Project Qtranslate X: before 3.4.4 — fixed in 3.4.4
How to fix
Upgrade to a fixed version: Qtranslate X Project Qtranslate X 3.4.4. Check the vendor advisory for mitigations.
References
- http://cinu.pl/research/wp-plugins/mail_1a40d7e7a2c29847b939f2c7472c335e.html
- https://wordpress.org/plugins/qtranslate-x/#developers
- https://wpvulndb.com/vulnerabilities/8279
- http://cinu.pl/research/wp-plugins/mail_1a40d7e7a2c29847b939f2c7472c335e.html
- https://wordpress.org/plugins/qtranslate-x/#developers
- https://wpvulndb.com/vulnerabilities/8279
Get alerted when CVE-2015-9431 or the next vulnerability affects your stack