What’s Vulnerable › Vulnerabilities
CVE-2015-9438
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The display-widgets plugin before 2.04 for WordPress has XSS via the wp-admin/admin-ajax.php?action=dw_show_widget id_base, widget_number, or instance parameter.
Affected products
- Display-Widgets Project Display-Widgets: before 2.04 — fixed in 2.04
How to fix
Upgrade to a fixed version: Display-Widgets Project Display-Widgets 2.04. Check the vendor advisory for mitigations.
References
- http://cinu.pl/research/wp-plugins/mail_a7012199c9236754edd72786637e5d2d.html
- https://wordpress.org/plugins/display-widgets/#developers
- https://wpvulndb.com/vulnerabilities/8247
- http://cinu.pl/research/wp-plugins/mail_a7012199c9236754edd72786637e5d2d.html
- https://wordpress.org/plugins/display-widgets/#developers
- https://wpvulndb.com/vulnerabilities/8247
Get alerted when CVE-2015-9438 or the next vulnerability affects your stack