What’s Vulnerable › Vulnerabilities
CVE-2015-9457
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-10-10 · updated 2026-06-17
- Weakness: CWE-89
Description
The pretty-link plugin before 1.6.8 for WordPress has PrliLinksController::list_links SQL injection via the group parameter.
Affected products
- Caseproof Prettylinks: before 1.6.8 — fixed in 1.6.8
How to fix
Upgrade to a fixed version: Caseproof Prettylinks 1.6.8. Check the vendor advisory for mitigations.
References
- http://cinu.pl/research/wp-plugins/mail_9ca443a3759e5c7fd889ae0e02e044e6.html
- https://wordpress.org/plugins/pretty-link/#developers
- https://wpvulndb.com/vulnerabilities/8249
- http://cinu.pl/research/wp-plugins/mail_9ca443a3759e5c7fd889ae0e02e044e6.html
- https://wordpress.org/plugins/pretty-link/#developers
- https://wpvulndb.com/vulnerabilities/8249
Get alerted when CVE-2015-9457 or the next vulnerability affects your stack