What’s Vulnerable › Vulnerabilities
CVE-2015-9501
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The Artificial Intelligence theme before 1.2.4 for WordPress has XSS because Genericons HTML files are unnecessarily placed under the web root.
Affected products
- Drupal AI (Artificial Intelligence): before 1.2.4 — fixed in 1.2.4
How to fix
Upgrade to a fixed version: Drupal AI (Artificial Intelligence) 1.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/duchenerc/artificial-intelligence/commit/c70631b1f80518411df2f88476041351110c6eac
- https://wpvulndb.com/vulnerabilities/7994
- https://github.com/duchenerc/artificial-intelligence/commit/c70631b1f80518411df2f88476041351110c6eac
- https://wpvulndb.com/vulnerabilities/7994
Get alerted when CVE-2015-9501 or the next vulnerability affects your stack