What’s Vulnerable › Vulnerabilities
CVE-2016-0264
- Severity: medium (CVSS 5.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-05-24 · updated 2026-06-17
- Weakness: CWE-119
Description
Buffer overflow in the Java Virtual Machine (JVM) in IBM SDK, Java Technology Edition 6 before SR16 FP25 (6.0.16.25), 6 R1 before SR8 FP25 (6.1.8.25), 7 before SR9 FP40 (7.0.9.40), 7 R1 before SR3 FP40 (7.1.3.40), and 8 before SR3 (8.0.3.0) allows remote attackers to execute arbitrary code via unspecified vectors.
Affected products
- IBM SDK, Java Technology Edition: from 6.0.0.0 before 6.0.16.25; from 6.1.0.0 before 6.1.8.25; from 7.0.0.0 before 7.0.9.40; from 7.1.0.0 before 7.1.3.40; from 8.0.0.0 before 8.0.3.0 — fixed in 6.0.16.25, 6.1.8.25, 7.0.9.40, 7.1.3.40, 8.0.3.0
- RedHat Enterprise Linux Desktop: 5.0, 6.0, 7.0
- RedHat Enterprise Linux Hpc Node Supplementary: 6.0, 7.0
- RedHat Enterprise Linux Server: 5.0, 6.0, 7.0
- RedHat Enterprise Linux Server Eus: 6.7, 7.2, 7.3, 7.4, 7.5
- RedHat Enterprise Linux Workstation: 5.0, 6.0, 7.0
- Red Hat Satellite 6: 5.6, 5.7
- SUSE Linux Enterprise Server: 11-sp4, 10-sp4, 11-sp2, 11-sp3, 12-sp1
- SUSE Linux Enterprise Software Development Kit: 11-sp4, 12, 12-sp1
- SUSE Manager: 2.1
- SUSE Manager Proxy: 2.1
- SUSE Openstack Cloud: 5
- SUSE Linux Enterprise: 12
How to fix
Upgrade to a fixed version: IBM SDK, Java Technology Edition 6.0.16.25, 6.1.8.25, 7.0.9.40, 7.1.3.40. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00039.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00040.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00042.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00058.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00059.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00061.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00067.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00002.html
- http://rhn.redhat.com/errata/RHSA-2016-0701.html
- http://rhn.redhat.com/errata/RHSA-2016-0702.html
- http://rhn.redhat.com/errata/RHSA-2016-0708.html
- http://rhn.redhat.com/errata/RHSA-2016-0716.html
Get alerted when CVE-2016-0264 or the next vulnerability affects your stack