What’s Vulnerable › Vulnerabilities
CVE-2016-0546
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-01-21 · updated 2026-06-17
Description
Unspecified vulnerability in Oracle MySQL 5.5.46 and earlier, 5.6.27 and earlier, and 5.7.9 and MariaDB before 5.5.47, 10.0.x before 10.0.23, and 10.1.x before 10.1.10 allows local users to affect confidentiality, integrity, and availability via unknown vectors related to Client. NOTE: the previous information is from the January 2016 CPU. Oracle has not commented on third-party claims that these are multiple buffer overflows in the mysqlshow tool that allow remote database servers to have unspecified impact via a long table or database name.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04, 15.10
- Debian Linux: 8.0
- MariaDB: from 5.5.20 before 5.5.47; from 10.0.0 before 10.0.23; from 10.1.0 before 10.1.10 — fixed in 10.0.23, 10.1.10, 5.5.47
- openSUSE Leap: 42.1
- Opensuse: 13.2
- Oracle Corporation Oracle Linux: 7
- MySQL Server: from 5.5.0 through 5.5.46; from 5.6.0 through 5.6.27; from 5.7.0 through 5.7.9
- Oracle Corporation Solaris Operating System: 11.3
- Red Hat Enterprise Linux: 6.0, 7.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Hpc Node: 7.0
- RedHat Enterprise Linux Hpc Node Eus: 7.2
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.2
- RedHat Enterprise Linux Server Eus: 7.2
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: MariaDB 10.0.23, 10.1.10, 5.5.47. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00015.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00016.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00033.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00034.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00051.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00053.html
- http://rhn.redhat.com/errata/RHSA-2016-0534.html
- http://rhn.redhat.com/errata/RHSA-2016-0705.html
- http://rhn.redhat.com/errata/RHSA-2016-1480.html
- http://rhn.redhat.com/errata/RHSA-2016-1481.html
- http://www.debian.org/security/2016/dsa-3453
- http://www.debian.org/security/2016/dsa-3459
Get alerted when CVE-2016-0546 or the next vulnerability affects your stack