What’s Vulnerable › Vulnerabilities
CVE-2016-0666
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-04-21 · updated 2026-06-17
Description
Unspecified vulnerability in Oracle MySQL 5.5.48 and earlier, 5.6.29 and earlier, and 5.7.11 and earlier and MariaDB before 5.5.49, 10.0.x before 10.0.25, and 10.1.x before 10.1.14 allows local users to affect availability via vectors related to Security: Privileges.
Affected products
- Debian Linux: 8.0
- IBM Powerkvm: 2.1, 3.1
- MariaDB: from 5.5.20 before 5.5.49; from 10.0.0 before 10.0.25; from 10.1.0 before 10.1.14 — fixed in 10.0.25, 10.1.14, 5.5.49
- openSUSE Leap: 42.1
- Oracle Corporation Oracle Linux: 7
- MySQL Server: from 5.5.0 through 5.5.48; from 5.6.0 through 5.6.29; from 5.7.0 through 5.7.11
- Red Hat Enterprise Linux: 6.0, 7.0
How to fix
Upgrade to a fixed version: MariaDB 10.0.25, 10.1.14, 5.5.49. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00035.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00053.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00033.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00034.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00051.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00053.html
- http://rhn.redhat.com/errata/RHSA-2016-0705.html
- http://rhn.redhat.com/errata/RHSA-2016-1480.html
- http://rhn.redhat.com/errata/RHSA-2016-1481.html
- http://rhn.redhat.com/errata/RHSA-2016-1602.html
- http://www-01.ibm.com/support/docview.wss?uid=isg3T1024168
- http://www.debian.org/security/2016/dsa-3557
Get alerted when CVE-2016-0666 or the next vulnerability affects your stack