What’s Vulnerable › Vulnerabilities
CVE-2016-0728
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-02-08 · updated 2026-06-17
Description
The join_session_keyring function in security/keys/process_keys.c in the Linux kernel before 4.4.1 mishandles object references in a certain error case, which allows local users to gain privileges or cause a denial of service (integer overflow and use-after-free) via crafted keyctl commands.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04, 15.10
- Debian Linux: 8.0
- Android: 4.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.1 (+18)
- HP Server Migration Pack: through 7.5
- Linux kernel: from 3.8 before 3.10.95; from 3.11 before 3.12.53; from 3.13 before 3.14.59; from 3.15 before 3.16.35; from 3.17 before 3.18.26; from 3.19 before 4.1.16 — fixed in 3.10.95, 3.12.53, 3.14.59, 3.16.35, 3.18.26, 4.1.16
How to fix
Upgrade to a fixed version: Linux kernel 3.10.95, 3.12.53, 3.14.59, 3.16.35. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=23567fd052a9abb6d67fe8e7a9ccdd9800a540f2
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/176484.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-January/176194.html
- http://lists.opensuse.org/opensuse-security-announce/2016-01/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00033.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00034.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00035.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00038.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00039.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00040.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00041.html
Get alerted when CVE-2016-0728 or the next vulnerability affects your stack