What’s Vulnerable › Vulnerabilities

CVE-2016-0752: Ruby on Rails Directory Traversal Vulnerability

Description

Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 allows remote attackers to read arbitrary files by leveraging an application's unrestricted use of the render method and providing a .. (dot dot) in a pathname.

Affected products

How to fix

Upgrade to a fixed version: Ruby on Rails 3.2.22.1, 4.1.14.1, 4.2.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-0752 or the next vulnerability affects your stack