What’s Vulnerable › Vulnerabilities

CVE-2016-0753

Description

Active Model in Ruby on Rails 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 supports the use of instance-level writers for class accessors, which allows remote attackers to bypass intended validation steps via crafted parameters.

Affected products

How to fix

Upgrade to a fixed version: Ruby on Rails 4.1.14.1, 4.2.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-0753 or the next vulnerability affects your stack