What’s Vulnerable › Vulnerabilities
CVE-2016-0758
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-06-27 · updated 2026-06-17
Description
Integer overflow in lib/asn1_decoder.c in the Linux kernel before 4.6 allows local users to gain privileges via crafted ASN.1 data.
Affected products
- Canonical Ubuntu Linux: 16.04
- Linux kernel: from 3.7 before 3.12.60; from 3.13 before 3.16.36; from 3.17 before 3.18.54; from 3.19 before 4.4.21 — fixed in 3.12.60, 3.16.36, 3.18.54, 4.4.21
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Hpc Node: 7.0
- RedHat Enterprise Linux Hpc Node Eus: 7.2
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.2
- RedHat Enterprise Linux Server Eus: 7.2
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Linux kernel 3.12.60, 3.16.36, 3.18.54, 4.4.21. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=23c8a812dc3c621009e4f0e5342aa4e2ede1ceaa
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00044.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00052.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00054.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00003.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00014.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00015.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00016.html
Get alerted when CVE-2016-0758 or the next vulnerability affects your stack