What’s Vulnerable › Vulnerabilities
CVE-2016-0766
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-02-17 · updated 2026-06-17
- Weakness: CWE-264
Description
PostgreSQL before 9.1.20, 9.2.x before 9.2.15, 9.3.x before 9.3.11, 9.4.x before 9.4.6, and 9.5.x before 9.5.1 does not properly restrict access to unspecified custom configuration settings (GUCS) for PL/Java, which allows attackers to gain privileges via unspecified vectors.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10
- Debian Linux: 7.0, 8.0
- PostgreSQL: from 9.1.0 before 9.1.20; from 9.2 before 9.2.15; from 9.3 before 9.3.11; from 9.4 before 9.4.6; 9.5 — fixed in 9.1.20, 9.2.15, 9.3.11, 9.4.6
How to fix
Upgrade to a fixed version: PostgreSQL 9.1.20, 9.2.15, 9.3.11, 9.4.6. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00049.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00052.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00054.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00056.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00016.html
- http://www.debian.org/security/2016/dsa-3475
- http://www.debian.org/security/2016/dsa-3476
- http://www.postgresql.org/about/news/1644/
- http://www.postgresql.org/docs/current/static/release-9-1-20.html
- http://www.postgresql.org/docs/current/static/release-9-2-15.html
- http://www.postgresql.org/docs/current/static/release-9-3-11.html
- http://www.postgresql.org/docs/current/static/release-9-4-6.html
Get alerted when CVE-2016-0766 or the next vulnerability affects your stack