What’s Vulnerable › Vulnerabilities
CVE-2016-0785
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-04-12 · updated 2026-06-17
- Weakness: CWE-20
Description
Apache Struts 2.x before 2.3.28 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double OGNL evaluation.
Affected products
- Apache Struts: from 2.0.0 before 2.3.20.3; from 2.3.21 through 2.3.24.1 — fixed in 2.3.20.3
How to fix
Upgrade to a fixed version: Apache Struts 2.3.20.3. Check the vendor advisory for mitigations.
References
- http://struts.apache.org/docs/s2-029.html
- http://www.securityfocus.com/bid/85066
- http://www.securitytracker.com/id/1035271
- http://struts.apache.org/docs/s2-029.html
- http://www.securityfocus.com/bid/85066
- http://www.securitytracker.com/id/1035271
Get alerted when CVE-2016-0785 or the next vulnerability affects your stack