What’s Vulnerable › Vulnerabilities

CVE-2016-0797

Description

Multiple integer overflows in OpenSSL 1.0.1 before 1.0.1s and 1.0.2 before 1.0.2g allow remote attackers to cause a denial of service (heap memory corruption or NULL pointer dereference) or possibly have unspecified other impact via a long digit string that is mishandled by the (1) BN_dec2bn or (2) BN_hex2bn function, related to crypto/bn/bn.h and crypto/bn/bn_print.c.

Affected products

How to fix

Upgrade to a fixed version: Node.js 4.1.2, 4.3.2, 5.7.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-0797 or the next vulnerability affects your stack