What’s Vulnerable › Vulnerabilities
CVE-2016-0923
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-09-18 · updated 2026-06-17
- Weakness: CWE-327
Description
The client in EMC RSA BSAFE Micro Edition Suite (MES) 4.0.x before 4.0.9 and 4.1.x before 4.1.5 places the weakest algorithms first in a signature-algorithm list transmitted to a server, which makes it easier for remote attackers to defeat cryptographic protection mechanisms by leveraging server behavior in which the first algorithm is used.
Affected products
- Dell Bsafe: from 4.0.0 before 4.0.9; from 4.1.0 before 4.1.5 — fixed in 4.0.9, 4.1.5
How to fix
Upgrade to a fixed version: Dell Bsafe 4.0.9, 4.1.5. Check the vendor advisory for mitigations.
References
- http://seclists.org/bugtraq/2016/Sep/25
- http://www.securityfocus.com/bid/92994
- http://www.securitytracker.com/id/1036835
- http://seclists.org/bugtraq/2016/Sep/25
- http://www.securityfocus.com/bid/92994
- http://www.securitytracker.com/id/1036835
Get alerted when CVE-2016-0923 or the next vulnerability affects your stack