What’s Vulnerable › Vulnerabilities
CVE-2016-1000027
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 33.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-02 · updated 2026-10-07
- Weakness: CWE-502
Description
Pivotal Spring Framework through 5.3.16 suffers from a potential remote code execution (RCE) issue if used for Java deserialization of untrusted data. Depending on how the library is implemented within a product, this issue may or not occur, and authentication may be required. NOTE: the vendor's position is that untrusted data is not an intended use case. The product's behavior will not be changed because some users rely on deserialization of trusted data.
Affected products
- Spring Framework: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: Spring Framework 6.0.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-1000027
- https://github.com/spring-projects/spring-framework/issues/24434#issuecomment-579669626
- https://github.com/spring-projects/spring-framework/issues/24434#issuecomment-582313417
- https://github.com/spring-projects/spring-framework/issues/24434#issuecomment-744519525
- https://raw.githubusercontent.com/distributedweaknessfiling/cvelist/master/2016/1000xxx/CVE-2016-1000027.json
- https://security-tracker.debian.org/tracker/CVE-2016-1000027
- https://security.netapp.com/advisory/ntap-20230420-0009/
- https://spring.io/blog/2022/05/11/spring-framework-5-3-20-and-5-2-22-available-now
- https://www.tenable.com/security/research/tra-2016-20
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-1000027
- https://github.com/spring-projects/spring-framework/issues/24434#issuecomment-579669626
- https://github.com/spring-projects/spring-framework/issues/24434#issuecomment-582313417
Get alerted when CVE-2016-1000027 or the next vulnerability affects your stack