What’s Vulnerable › Vulnerabilities
CVE-2016-1000030
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-05 · updated 2026-06-17
- Weakness: CWE-295
Description
Pidgin version <2.11.0 contains a vulnerability in X.509 Certificates imports specifically due to improper check of return values from gnutls_x509_crt_init() and gnutls_x509_crt_import() that can result in code execution. This attack appear to be exploitable via custom X.509 certificate from another client. This vulnerability appears to have been fixed in 2.11.0.
Affected products
- Pidgin: before 2.11.0 — fixed in 2.11.0
- SUSE Linux Enterprise Server: 11-sp4
How to fix
Upgrade to a fixed version: Pidgin 2.11.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/cve-2016-1000030
- https://bitbucket.org/pidgin/main/commits/d6fc1ce76ffe
- https://pidgin.im/news/security/?id=91
- https://security.gentoo.org/glsa/201701-38
- https://www.suse.com/pt-br/security/cve/CVE-2016-1000030/
- https://access.redhat.com/security/cve/cve-2016-1000030
- https://bitbucket.org/pidgin/main/commits/d6fc1ce76ffe
- https://pidgin.im/news/security/?id=91
- https://security.gentoo.org/glsa/201701-38
- https://www.suse.com/pt-br/security/cve/CVE-2016-1000030/
Get alerted when CVE-2016-1000030 or the next vulnerability affects your stack