What’s Vulnerable › Vulnerabilities

CVE-2016-1000110

Description

The CGIHandler class in Python before 2.7.12 does not protect against the HTTP_PROXY variable name clash in a CGI script, which could allow a remote attacker to redirect HTTP requests.

Affected products

How to fix

Upgrade to a fixed version: Python 2.7.13, 3.3.7, 3.4.6, 3.5.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-1000110 or the next vulnerability affects your stack