What’s Vulnerable › Vulnerabilities
CVE-2016-10006
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-12-24 · updated 2026-06-17
- Weakness: CWE-79
Description
In OWASP AntiSamy before 1.5.5, by submitting a specially crafted input (a tag that supports style with active content), you could bypass the library protections and supply executable code. The impact is XSS.
Affected products
- nahsra antisamy: before 1.5.5 — fixed in 1.5.5
How to fix
Upgrade to a fixed version: nahsra antisamy 1.5.5. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95101
- http://www.securitytracker.com/id/1037532
- https://github.com/nahsra/antisamy/issues/2
- http://www.securityfocus.com/bid/95101
- http://www.securitytracker.com/id/1037532
- https://github.com/nahsra/antisamy/issues/2
Get alerted when CVE-2016-10006 or the next vulnerability affects your stack