What’s Vulnerable › Vulnerabilities
CVE-2016-10008
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-02-19 · updated 2026-06-17
- Weakness: CWE-89
Description
SQL injection vulnerability in the "Content Types > Content Types" screen in dotCMS before 3.7.2 and 4.x before 4.1.1 allows remote authenticated administrators to execute arbitrary SQL commands via the _EXT_STRUCTURE_direction parameter.
Affected products
- dotCMS core: before 3.7.2; from 4.0.0 before 4.1.1 — fixed in 3.7.2, 4.1.1
How to fix
Upgrade to a fixed version: dotCMS core 3.7.2, 4.1.1. Check the vendor advisory for mitigations.
References
- https://security.elarlang.eu/cve-2016-10007-and-cve-2016-10008-2-sql-injection-vulnerabilities-in-dotcms-blacklist-defence-bypass.html
- https://security.elarlang.eu/cve-2016-10007-and-cve-2016-10008-2-sql-injection-vulnerabilities-in-dotcms-blacklist-defence-bypass.html
Get alerted when CVE-2016-10008 or the next vulnerability affects your stack