What’s Vulnerable › Vulnerabilities
CVE-2016-10033: PHPMailer Command Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-07-07
- EPSS: 99.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-12-30 · updated 2026-06-17
- Weakness: CWE-88
Description
The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a \" (backslash double quote) in a crafted Sender property.
Affected products
- Joomla!: from 1.5.0 through 3.6.5
- Phpmailer Project Phpmailer: before 5.2.18 — fixed in 5.2.18
- WordPress: through 4.7
How to fix
Upgrade to a fixed version: Phpmailer Project Phpmailer 5.2.18. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/140291/PHPMailer-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/140350/PHPMailer-Sendmail-Argument-Injection.html
- http://seclists.org/fulldisclosure/2016/Dec/78
- http://www.rapid7.com/db/modules/exploit/multi/http/phpmailer_arg_injection
- http://www.securityfocus.com/archive/1/539963/100/0/threaded
- http://www.securityfocus.com/bid/95108
- http://www.securitytracker.com/id/1037533
- https://developer.joomla.org/security-centre/668-20161205-phpmailer-security-advisory.html
- https://github.com/PHPMailer/PHPMailer/releases/tag/v5.2.18
- https://github.com/PHPMailer/PHPMailer/wiki/About-the-CVE-2016-10033-and-CVE-2016-10045-vulnerabilities
- https://legalhackers.com/advisories/PHPMailer-Exploit-Remote-Code-Exec-CVE-2016-10033-Vuln.html
- https://www.drupal.org/psa-2016-004
Get alerted when CVE-2016-10033 or the next vulnerability affects your stack