What’s Vulnerable › Vulnerabilities

CVE-2016-10044

Description

The aio_mount function in fs/aio.c in the Linux kernel before 4.7.7 does not properly restrict execute access, which makes it easier for local users to bypass intended SELinux W^X policy restrictions, and consequently gain privileges, via an io_setup system call.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.16.43, 4.4.24, 4.7.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-10044 or the next vulnerability affects your stack