What’s Vulnerable › Vulnerabilities
CVE-2016-10045
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 97.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-12-30 · updated 2026-06-17
- Weakness: CWE-77
Description
The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code by leveraging improper interaction between the escapeshellarg function and internal escaping performed in the mail function in PHP. NOTE: this vulnerability exists because of an incorrect fix for CVE-2016-10033.
Affected products
- Joomla!: from 1.5.0 through 3.6.5
- Phpmailer Project Phpmailer: before 5.2.20 — fixed in 5.2.20
- WordPress: through 4.7
How to fix
Upgrade to a fixed version: Phpmailer Project Phpmailer 5.2.20. Check the vendor advisory for mitigations.
References
- http://openwall.com/lists/oss-security/2016/12/28/1
- http://packetstormsecurity.com/files/140286/PHPMailer-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/140350/PHPMailer-Sendmail-Argument-Injection.html
- http://seclists.org/fulldisclosure/2016/Dec/81
- http://www.rapid7.com/db/modules/exploit/multi/http/phpmailer_arg_injection
- http://www.securityfocus.com/archive/1/539967/100/0/threaded
- http://www.securityfocus.com/bid/95130
- http://www.securitytracker.com/id/1037533
- https://developer.joomla.org/security-centre/668-20161205-phpmailer-security-advisory.html
- https://github.com/PHPMailer/PHPMailer/releases/tag/v5.2.20
- https://github.com/PHPMailer/PHPMailer/wiki/About-the-CVE-2016-10033-and-CVE-2016-10045-vulnerabilities
- https://legalhackers.com/advisories/PHPMailer-Exploit-Remote-Code-Exec-CVE-2016-10045-Vuln-Patch-Bypass.html
Get alerted when CVE-2016-10045 or the next vulnerability affects your stack