What’s Vulnerable › Vulnerabilities
CVE-2016-10060
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-02 · updated 2026-06-17
- Weakness: CWE-252
Description
The ConcatenateImages function in MagickWand/magick-cli.c in ImageMagick before 7.0.1-10 does not check the return value of the fputc function, which allows remote attackers to cause a denial of service (application crash) via a crafted file.
Affected products
- ImageMagick: before 6.9.4-1; from 7.0.0-0 before 7.0.1-10 — fixed in 6.9.4-1, 7.0.1-10
How to fix
Upgrade to a fixed version: ImageMagick 6.9.4-1, 7.0.1-10. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/12/26/9
- http://www.securityfocus.com/bid/95208
- https://bugzilla.redhat.com/show_bug.cgi?id=1410470
- https://github.com/ImageMagick/ImageMagick/commit/933e96f01a8c889c7bf5ffd30020e86a02a046e7
- https://github.com/ImageMagick/ImageMagick/issues/196
- http://www.openwall.com/lists/oss-security/2016/12/26/9
- http://www.securityfocus.com/bid/95208
- https://bugzilla.redhat.com/show_bug.cgi?id=1410470
- https://github.com/ImageMagick/ImageMagick/commit/933e96f01a8c889c7bf5ffd30020e86a02a046e7
- https://github.com/ImageMagick/ImageMagick/issues/196
Get alerted when CVE-2016-10060 or the next vulnerability affects your stack