What’s Vulnerable › Vulnerabilities
CVE-2016-10144
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-24 · updated 2026-06-17
- Weakness: CWE-284
Description
coders/ipl.c in ImageMagick allows remote attackers to have unspecific impact by leveraging a missing malloc check.
Affected products
- ImageMagick: before 6.9.7-1 — fixed in 6.9.7-1
How to fix
Upgrade to a fixed version: ImageMagick 6.9.7-1. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3799
- http://www.openwall.com/lists/oss-security/2017/01/16/6
- http://www.openwall.com/lists/oss-security/2017/01/17/5
- http://www.securityfocus.com/bid/95750
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=851485
- https://github.com/ImageMagick/ImageMagick/commit/97566cf2806c0a5a86e884c96831a0c3b1ec6c20
- https://security.gentoo.org/glsa/201702-09
- http://www.debian.org/security/2017/dsa-3799
- http://www.openwall.com/lists/oss-security/2017/01/16/6
- http://www.openwall.com/lists/oss-security/2017/01/17/5
- http://www.securityfocus.com/bid/95750
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=851485
Get alerted when CVE-2016-10144 or the next vulnerability affects your stack