What’s Vulnerable › Vulnerabilities
CVE-2016-10146
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-24 · updated 2026-06-17
- Weakness: CWE-399
Description
Multiple memory leaks in the caption and label handling code in ImageMagick allow remote attackers to cause a denial of service (memory consumption) via unspecified vectors.
Affected products
- ImageMagick: before 6.9.6-8 — fixed in 6.9.6-8
How to fix
Upgrade to a fixed version: ImageMagick 6.9.6-8. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3799
- http://www.openwall.com/lists/oss-security/2017/01/16/6
- http://www.openwall.com/lists/oss-security/2017/01/17/5
- http://www.securityfocus.com/bid/95744
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=851380
- https://github.com/ImageMagick/ImageMagick/commit/aeff00de228bc5a158c2a975ab47845d8a1db456
- https://security.gentoo.org/glsa/201702-09
- http://www.debian.org/security/2017/dsa-3799
- http://www.openwall.com/lists/oss-security/2017/01/16/6
- http://www.openwall.com/lists/oss-security/2017/01/17/5
- http://www.securityfocus.com/bid/95744
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=851380
Get alerted when CVE-2016-10146 or the next vulnerability affects your stack