What’s Vulnerable › Vulnerabilities
CVE-2016-10159
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-01-24 · updated 2026-06-17
- Weakness: CWE-190
Description
Integer overflow in the phar_parse_pharfile function in ext/phar/phar.c in PHP before 5.6.30 and 7.0.x before 7.0.15 allows remote attackers to cause a denial of service (memory consumption or application crash) via a truncated manifest entry in a PHAR archive.
Affected products
- Debian Linux: 8.0
- PHP: through 5.6.29; from 7.0.0 before 7.0.15; 7.1.0 — fixed in 7.0.15
How to fix
Upgrade to a fixed version: PHP 7.0.15. Check the vendor advisory for mitigations.
References
- http://php.net/ChangeLog-5.php
- http://php.net/ChangeLog-7.php
- http://www.debian.org/security/2017/dsa-3783
- http://www.securityfocus.com/bid/95774
- http://www.securitytracker.com/id/1037659
- https://access.redhat.com/errata/RHSA-2018:1296
- https://bugs.php.net/bug.php?id=73764
- https://github.com/php/php-src/commit/ca46d0acbce55019b970fcd4c1e8a10edfdded93
- https://security.gentoo.org/glsa/201702-29
- https://security.netapp.com/advisory/ntap-20180112-0001/
- https://www.tenable.com/security/tns-2017-04
- http://php.net/ChangeLog-5.php
Get alerted when CVE-2016-10159 or the next vulnerability affects your stack