What’s Vulnerable › Vulnerabilities

CVE-2016-10160

Description

Off-by-one error in the phar_parse_pharfile function in ext/phar/phar.c in PHP before 5.6.30 and 7.0.x before 7.0.15 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via a crafted PHAR archive with an alias mismatch.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.6.30, 7.0.15, 7.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-10160 or the next vulnerability affects your stack