What’s Vulnerable › Vulnerabilities
CVE-2016-10196
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-03-15 · updated 2026-06-17
- Weakness: CWE-787
Description
Stack-based buffer overflow in the evutil_parse_sockaddr_port function in evutil.c in libevent before 2.1.6-beta allows attackers to cause a denial of service (segmentation fault) via vectors involving a long string in brackets in the ip_as_string argument.
Affected products
- Debian Linux: 8.0
- Libevent Project Libevent: through 2.1.5
- Mozilla Firefox: before 45.9.0; before 53.0; 52.0 — fixed in 45.9.0, 53.0
- Mozilla Thunderbird: before 52.1.0 — fixed in 52.1.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 45.9.0, 53.0; Mozilla Thunderbird 52.1.0. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3789
- http://www.openwall.com/lists/oss-security/2017/01/31/17
- http://www.openwall.com/lists/oss-security/2017/02/02/7
- http://www.securityfocus.com/bid/96014
- http://www.securitytracker.com/id/1038320
- https://access.redhat.com/errata/RHSA-2017:1104
- https://access.redhat.com/errata/RHSA-2017:1106
- https://access.redhat.com/errata/RHSA-2017:1201
- https://bugzilla.mozilla.org/show_bug.cgi?id=1343453
- https://github.com/libevent/libevent/blob/release-2.1.6-beta/ChangeLog
- https://github.com/libevent/libevent/commit/329acc18a0768c21ba22522f01a5c7f46cacc4d5
- https://github.com/libevent/libevent/issues/318
Get alerted when CVE-2016-10196 or the next vulnerability affects your stack