What’s Vulnerable › Vulnerabilities
CVE-2016-10516
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-10-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the render_full function in debug/tbtools.py in the debugger in Pallets Werkzeug before 0.11.11 (as used in Pallets Flask and other products) allows remote attackers to inject arbitrary web script or HTML via a field that contains an exception message.
Affected products
- pallets werkzeug: before 0.11.11 — fixed in 0.11.11
How to fix
Upgrade to a fixed version: pallets werkzeug 0.11.11. Check the vendor advisory for mitigations.
References
- http://blog.neargle.com/2016/09/21/flask-src-review-get-a-xss-from-debuger/
- https://github.com/pallets/werkzeug/pull/1001
- https://lists.debian.org/debian-lts-announce/2017/11/msg00037.html
- http://blog.neargle.com/2016/09/21/flask-src-review-get-a-xss-from-debuger/
- https://github.com/pallets/werkzeug/pull/1001
- https://lists.debian.org/debian-lts-announce/2017/11/msg00037.html
Get alerted when CVE-2016-10516 or the next vulnerability affects your stack