What’s Vulnerable › Vulnerabilities
CVE-2016-10522
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-05 · updated 2026-06-17
- Weakness: CWE-352
Description
rails_admin ruby gem <v1.1.1 is vulnerable to cross-site request forgery (CSRF) attacks. Non-GET methods were not validating CSRF tokens and, as a result, an attacker could hypothetically gain access to the application administrative endpoints exposed by the gem.
Affected products
- https://github.com/sferik rails_admin ruby gem: before 1.1.1 — fixed in 1.1.1
How to fix
Upgrade to a fixed version: https://github.com/sferik rails_admin ruby gem 1.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/sferik/rails_admin/commit/b13e879eb93b661204e9fb5e55f7afa4f397537a
- https://www.sourceclear.com/blog/Rails_admin-Vulnerability-Disclosure/
- https://www.sourceclear.com/registry/security/cross-site-request-forgery-csrf-/ruby/sid-3173
- https://github.com/sferik/rails_admin/commit/b13e879eb93b661204e9fb5e55f7afa4f397537a
- https://www.sourceclear.com/blog/Rails_admin-Vulnerability-Disclosure/
- https://www.sourceclear.com/registry/security/cross-site-request-forgery-csrf-/ruby/sid-3173
Get alerted when CVE-2016-10522 or the next vulnerability affects your stack