What’s Vulnerable › Vulnerabilities
CVE-2016-10523
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-05-31 · updated 2026-06-17
- Weakness: CWE-400
Description
MQTT before 3.4.6 and 4.0.x before 4.0.5 allows specifically crafted MQTT packets to crash the application, making a DoS attack feasible with very little bandwidth.
Affected products
- mqtt-packet: before 3.4.6; from 4.0.0 before 4.0.5 — fixed in 3.4.6, 4.0.5
How to fix
Upgrade to a fixed version: mqtt-packet 3.4.6, 4.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/mcollina/mosca/issues/393
- https://github.com/mqttjs/mqtt-packet/pull/8
- https://nodesecurity.io/advisories/75
- https://github.com/mcollina/mosca/issues/393
- https://github.com/mqttjs/mqtt-packet/pull/8
- https://nodesecurity.io/advisories/75
Get alerted when CVE-2016-10523 or the next vulnerability affects your stack