What’s Vulnerable › Vulnerabilities
CVE-2016-10524
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-31 · updated 2026-06-17
- Weakness: CWE-400
Description
i18n-node-angular is a module used to interact between i18n and angular without using additional resources. A REST API endpoint that is used for development in i18n-node-angular before 1.4.0 was not disabled in production environments a malicious user could fill up the server causing a Denial of Service or content injection.
Affected products
- HackerOne i18n-node-angular node module: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: HackerOne i18n-node-angular node module 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/oliversalzburg/i18n-node-angular/commit/877720d2d9bb90dc8233706e81ffa03f99fc9dc8
- https://nodesecurity.io/advisories/80
- https://github.com/oliversalzburg/i18n-node-angular/commit/877720d2d9bb90dc8233706e81ffa03f99fc9dc8
- https://nodesecurity.io/advisories/80
Get alerted when CVE-2016-10524 or the next vulnerability affects your stack