What’s Vulnerable › Vulnerabilities
CVE-2016-10529
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-31 · updated 2026-06-17
- Weakness: CWE-352
Description
Droppy versions <3.5.0 does not perform any verification for cross-domain websocket requests. An attacker is able to make a specially crafted page that can send requests as the context of the currently logged in user. For example this means the malicious user could add a new admin account under his control and delete others.
Affected products
- HackerOne droppy node module: before 3.5.0 — fixed in 3.5.0
How to fix
Upgrade to a fixed version: HackerOne droppy node module 3.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2016-10529 or the next vulnerability affects your stack