What’s Vulnerable › Vulnerabilities
CVE-2016-10538
- Severity: low (CVSS 3.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-05-31 · updated 2026-06-17
- Weakness: CWE-22
Description
The package `node-cli` before 1.0.0 insecurely uses the lock_file and log_file. Both of these are temporary, but it allows the starting user to overwrite any file they have access to.
Affected products
- Cli Project Cli: before 1.0.0 — fixed in 1.0.0
- Debian Linux: 8.0
How to fix
Upgrade to a fixed version: Cli Project Cli 1.0.0. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=809252
- https://github.com/node-js-libs/cli/issues/81
- https://nodesecurity.io/advisories/95
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=809252
- https://github.com/node-js-libs/cli/issues/81
- https://nodesecurity.io/advisories/95
Get alerted when CVE-2016-10538 or the next vulnerability affects your stack