What’s Vulnerable › Vulnerabilities
CVE-2016-10541
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-05-31 · updated 2026-06-17
- Weakness: CWE-78
Description
The npm module "shell-quote" 1.6.0 and earlier cannot correctly escape ">" and "<" operator used for redirection in shell. Applications that depend on shell-quote may also be vulnerable. A malicious user could perform code injection.
Affected products
- ljharb shell-quote: before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: ljharb shell-quote 1.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-qg8p-v9q4-gh34
- https://nodesecurity.io/advisories/117
- https://github.com/advisories/GHSA-qg8p-v9q4-gh34
- https://nodesecurity.io/advisories/117
Get alerted when CVE-2016-10541 or the next vulnerability affects your stack