What’s Vulnerable › Vulnerabilities
CVE-2016-10558
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-29 · updated 2026-06-17
- Weakness: CWE-311
Description
aerospike is an Aerospike add-on module for Node.js. aerospike versions below 2.4.2 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Affected products
- HackerOne aerospike node module: before 2.4.2 — fixed in 2.4.2
How to fix
Upgrade to a fixed version: HackerOne aerospike node module 2.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2016-10558 or the next vulnerability affects your stack