What’s Vulnerable › Vulnerabilities
CVE-2016-10563
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-31 · updated 2026-06-17
- Weakness: CWE-311
Description
During the installation process, the go-ipfs-deps module before 0.4.4 insecurely downloads resources over HTTP. This allows for a MITM attack to compromise the integrity of the resources used by this module and could allow for further compromise.
Affected products
- HackerOne go-ipfs-dep node module: before 0.4.4 — fixed in 0.4.4
How to fix
Upgrade to a fixed version: HackerOne go-ipfs-dep node module 0.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/diasdavid/go-ipfs-dep/pull/12
- https://nodesecurity.io/advisories/156
- https://github.com/diasdavid/go-ipfs-dep/pull/12
- https://nodesecurity.io/advisories/156
Get alerted when CVE-2016-10563 or the next vulnerability affects your stack